Browser Requirements

SmartBen requires that both cookies and javascript be enabled to use the web site. The current, supported browsers for using the SmartBen Web site are:

Windows Mac Linux/Unix
Internet Explorer IE 7+
Netscape Netscape 6.1+
FireFox FireFox 1.0+
Opera Opera 6+
Mozilla Mozilla 0.9+
Safari Safari 1.0+
Opera Opera 6+
FireFox FireFox
Netscape Netscape 6.1+
Mozilla Mozilla 0.9+
Opera Opera 6+
Konqueror Konqueror 3.5+

If you are having display problems, try switching to a different browser. For best viewing, use the most recent version of a browser. Free upgrades are available at the following sites:

Plug-Ins

To maximize all features of the SmartBen system members must have a supported browser and certain files require Adobe Acrobat Reader to view or print PDFs. SmartBen also uses the Adobe Flash Plug-In to view help tutorials and plan storyboards. If you do not currently have access to the Adobe Flash Plug-In, you can download the plug-in, which is publicly accessible via the Adobe Web Site.